Uploads from pouria

Watch and track your favorite playlist.

Curated by: pouria (9 videos)


Currently Playing: 6 Authentication Concepts EVERY SRE Should Know

HMAC, keypairs, digital certificates, JWT, mTLS, and workload identity federation This video is built for learning! To keep things clear, some details have been oversimplified. Chapters 0:00 HMAC 1:55 Keypairs 3:58 Digital certificates 5:53 JWT 7:13 mTLS 8:15 Workload identity federation Contact tajpouria.dev@gmail.com https://github.com/tajpouria References HMAC: Keyed-Hashing for Message Authentication (RFC 2104) https://www.rfc-editor.org/rfc/rfc2104.txt Internet X.509 Public Key Infrastructure Certificate and CRL Profile (RFC 5280) https://www.rfc-editor.org/rfc/rfc5280.txt Automatic Certificate Management Environment (ACME) (RFC 8555) https://www.rfc-editor.org/rfc/rfc8555.txt JSON Web Token (JWT) (RFC 7519) https://www.rfc-editor.org/rfc/rfc7519.txt The Transport Layer Security (TLS) Protocol Version 1.3 (RFC 8446) https://www.rfc-editor.org/rfc/rfc8446.txt Istio Security https://istio.io/latest/docs/concepts/security/ GitHub Actions: OpenID Connect https://docs.github.com/en/actions/concepts/security/openid-connect SPIFFE: Secure Production Identity Framework for Everyone https://github.com/spiffe/spiffe/blob/main/standards/SPIFFE.md Media CGI Snake by Chris Zabriskie is licensed under a Creative Commons Attribution 4.0 license. https://creativecommons.org/licenses/by/4.0/ Source: http://chriszabriskie.com/divider/ Artist: http://chriszabriskie.com/ Air Hockey Saloon by Chris Zabriskie is licensed under a Creative Commons Attribution 4.0 license. https://creativecommons.org/licenses/by/4.0/ Source: http://chriszabriskie.com/vendaface/ Artist: http://chriszabriskie.com/ #authentication #jwt #mtls #hmac #oidc


Tracks in this Playlist